WebClient 5

Jump to solution

Hallo zusammen,

ich habe in unserem Projekt den WebClient aktiviert und konfiguriert wie in dem Handbuch für Administratoren beschrieben.

Wenn ich nun das Projekt im WebClient aufrufe, passiert folgendes:
Während das Projekt geladen wird, ist die WebEdit Toolbar sichtbar, anschliessend nicht mehr und die URL erinnert eher an die Preview als an eine WebClient URL:
http://domain:port/fs5webedit/preview/1313228/site/EN/current/1313259/1382978

Das Projekt Mithras_demo dagegen läuft im WebClient.

Fehlt noch irgendwas an der Konfiguration?

Viele Grüße
Alex

0 Kudos
1 Solution

Accepted Solutions
johni
I'm new here

Re: WebClient 5

Jump to solution

Es sieht sehr danach aus, dass deine Webseite versucht aus dem Frame auszubrechen in dem sie normalerweise im Webedit läuft.

Hast du eventuell irgendein Framebraker Javascript (irgendetwas, dass top.location manipuliert), Links mit target="_top" auf der seite oder eventuell eine Browsererweiterung aktiv, die das verursachen könnte?

View solution in original post

0 Kudos
4 Replies
MichaelaReydt
Community Manager
Community Manager

Re: WebClient 5

Jump to solution

Hallo Alex,

die URL erinnert in der Tat an die Preview.

Ich habe versucht, die beschriebene Situation bei mir lokal nachzustellen, eine Reproduktion jedoch nicht erreicht.

Kannst Du mir daher Deine FS-Version nennen und beschreiben, wie deine WebClient-Konfiguration konkret aussieht? Unterscheidet sie sich von der Konfiguration des funktionierenden Mithras-Demo-Projekts?

Viele Grüße,

Michaela

0 Kudos
johni
I'm new here

Re: WebClient 5

Jump to solution

Es sieht sehr danach aus, dass deine Webseite versucht aus dem Frame auszubrechen in dem sie normalerweise im Webedit läuft.

Hast du eventuell irgendein Framebraker Javascript (irgendetwas, dass top.location manipuliert), Links mit target="_top" auf der seite oder eventuell eine Browsererweiterung aktiv, die das verursachen könnte?

0 Kudos
rednoss
I'm new here

Re: WebClient 5

Jump to solution

Hallo Alex,

ist Dein Problem noch aktuell oder konntest du es in der Zwischenzeit lösen? Wenn ja, wie konntest du den Fehler beheben?

Grüße

René

0 Kudos

Re: WebClient 5

Jump to solution

Hallo Rene,

hab den Thread nicht mehr verfolgt, da ich das Problem relativ schnell gefixt hatte. Ich hatte eine JS-Funktion, die die Url manipuliert hat.

Gruß Alex

0 Kudos