markusbucher
I'm new here

Fehler beim Deployment "No target selected" und logfiles

Hallo,

bei dem Deployen erhalten wir viele Fehler, die durch ungültige Referenzen in Content Projektionen entstehen. (No target selected).

In den Logfiles erhalten wir aber nur die Referenz auf die ContentProjection selbst, nicht jedoch Informationen über den Datensatz, der fehl schlägt. Wie können wir diesen herausfinden? Lässt sich das Error Log derart erweitern, dass auch die ID des Datensatzes ausgegeben wird?

Danke und Gruß

Markus

Labels (1)
0 Kudos
3 Replies
marro
e-Spirit employee

Re: Fehler beim Deployment "No target selected" und logfiles

Hallo Markus,

ich hab versucht, den Fall nachzustellen, und erhalte bei der Generierung folgende Fehlermeldung:

ERROR 28.04.2016 10:25:13.500{g-sec=6739,g-node=6738,g-entity=Press_Releases(131)} (de.espirit.firstspirit.generate.SiteProduction): no target selected

          inside of: Template 'Standard' (id=6020)

          inside of: $CMS_TRIM(level:1, char:)$ - at 223, 3

          inside of: $CMS_VALUE(#global.page.body("Content center"))$ - at 386, 9

          inside of: Template 'Pressemitteilungen' (id=6040)

          inside of: $CMS_VALUE(cs_content)$ - at 98, 4

          inside of: Template 'Text / Bild' (id=6039)

          inside of: $CMS_IF(  ! st_picture.isEmpty )$ - at 8, 2

          inside of: $CMS_REF(st_picture, resolution:"TextBildTeaser")$ - at 34, 17

Die ID des Datensatzes, der die Fehlermeldung verursacht, steht dabei in der ersten Zeile im Attribut g-entity (in diesem Fall war es der Datensatz mit der ID 131).

Hilft Dir das weiter?

Viele Grüße

Donato

0 Kudos
LVanselow
I'm new here

Re: Fehler beim Deployment "No target selected" und logfiles

Hallo Markus,

um diesen Fehler zu vermeiden, könntet ihr vor dem Aufruf von CMS_REF folgende Abfrage einbauen (vorausgesetzt ihr verwendet FS_REFERENCE):

$CMS_IF(st_image.get() != null)$

    $CMS_REF(st_image, abs:1, res:"res1")$

$CMS_END_IF$

Das nur als Vorschlag.

VG

Lars

0 Kudos
chwal
e-Spirit employee

Re: Fehler beim Deployment "No target selected" und logfiles

Hallo Markus,

benötigst Du noch weitere Hilfe oder haben Dir die oberen Antworten bereits geholfen?

In diesem Fall wäre es super, wenn Du die "richtige Antwort" entsprechend markierst, damit auch andere

Community-Teilnehmer diese auf den ersten Blick finden. Solltest Du zwischenzeitlich eine eigene Lösung

gefunden haben, wäre es nett, wenn Du diese hier bereitstellst.

Viele Grüße

Sebastian

0 Kudos