Occasional Observer


Hello everybody,

I used a FS_INDEX in order to make a connection between 2 or more elements.

In Data Source I made some examples to show to the customer. I choose one dataset, reference another 2 elements to it and then save and close.

By reopening the FirstSpirit Client my referenced elements are still in the database but are not referenced anymore to the dataset. It's like I never referenced them.

Any Ideas?

4 Replies
New Responder

Hi Carmen, if you are talking about a table template, please check if you configured the mapping correctly. Cheers, Heiko

Hello Heiko,

thank you for replying! Yes I thought of that too and checked it. The mappings are correct. And yes I am talking about table template.


0 Kudos

Hi Carmen,

can you post a screenshot of the mapping and formular definition of the table template and the table in the schema as well? It's hard to say what went wrong without seeing the sources. As Heiko mentioned, that kind of error normally occurs if FirstSpirit does not actually save the data. The UI lies to you in that case.

Other places you might want to check:

  • If it's saved in a database you can access, investigate if the field was actually saved.
  • You may want to check the schema XML for any obvious error. It can be accessed from the context menu when right clicking the schema (not the table template) and choosing something in the lines of "edit eternally". Not sure about the exact wording right now.
0 Kudos


I solved the Problem this way:

Having used FS_INDEX for the reference I thought of trying to get the same result I wanted with FS_CATALOG. In doing this I had to map the new fields and the problem dissapeared.


Thank you for the support and assistance.

0 Kudos