I'm new here

Addendum for Installation Instructions on Unix: non-ASCII characters in filenames

Setting character encoding of Operating System for

filenames with non-ASCII characters

on FirstSpirit Server

This addendum complements:

    PDF: Installation Instructions FirstSpirit 5.0

    Chapters: 2. Installation under GNU/Linux, Solaris or AIX


Filenames created by FirstSpirit Server are written with character ? instead of German umlaut or other non-ASCII characters. Usually this applies to filenames in folders /opt/firstspirit5/web/fs5root/help/odfs and /opt/firstspirit5/web/fs5webedit/help/webclient and files generated by projects in folder /opt/firstspirit5/web/fs5staging.


As root, stop FirstSpirit Server:

service fs5 stop

Check, if your operating system offers a character encoding supporting non-ASCII in filenames. Usually this is en_US.UTF-8:

locale -a | grep -i en_us

Add the following line in file /opt/firstspirit5/conf/fs-wrapper.conf at any location, for example below the line "wrapper.umask". Replace en_US.UTF-8 if your operating system does not offer that specific one.


Remove internal web application files, they will be replaced on next start:

rm -rf /opt/firstspirit5/web/fs5root

As root, start FirstSpirit Server:

service fs5 start

Verify, if files in folder /opt/firstspirit5/web/fs5root are written correctly now. If strange control characters are visible instead of German umlauts,verify your Shell and Terminal character encoding and set it to UTF-8 with the setting in the Terminal Client and via "export LC_CTYPE=en_US.UTF-8; unset LANG" in the Shell.

If external Application Servers are used for FirstSpirit WebApps instead of the embedded Jetty Application Server, the local settings must be set there. Recommended is to set LC_ALL as FirstSpirit WebApps are evaluating the locale settings for instance in the ServerMonitor WebApp. For Tomcat add the following line to tomcat/bin/, for other WebApp server use comparable settings:

export LC_ALL=en_US.UTF-8