ContentCreator > Hide TRANSLATED in Global Content Form

Goal: Lesser confusion for editors

Who: Editors in Content Creator


In the Site Architect in the Global Content the options for TRANSLATED are not shown as they are always true there.

In the Content Creater the option is shown, can be changed, but always reverts to true anyway. This can be confusing for the editor.

Please remove the checkmark before the language in the Content Creator when editing a global content part!