Noumena
I'm new here

Zugriff auf XML-Daten aus einer DQ funktioniert nicht mehr in FS5

Hallo,

nach dem Update von FS4 auf die Version 5.2_BETA.32.68448 werden einige Daten aus den Datenquellen im Template nicht mehr ausgegeben. Die Gemeinsamkeit dieser Spalten ist der Spaltentyp XML (FirstSpirit-EDITOR).

Ein konkretes Beispiel aus unserem Projekt:

Datenbankspalte: picture (XML)

Formular in der Tabellenvorlage: dtPicture vom Typ FS_REFERENCE (verweist auf ein Medium)

Beim Mapping wird die Spalte picture auf dtPicture korrekt gemappt.

Zugegriffen wird mit #row.picture, was allerdings ein leeres Ergebnis zurück liefert.

Andere Spalten (z.B. vom Typ String) auf die auf die selben Art und Weise zugegriffen wird, funktionieren. Das Problem betrifft nicht nur die picture-Spalte, sondern auch weitere aus der selben Tabelle.

Ist dies auch noch in FS5 der korrekte Weg um auf Werte aus einer Datenquelle zuzugreifen bzw. hat sich etwas bei dem Zugriff auf XML-Daten geändert?

Viele Grüße aus Berlin.

Labels (1)
2 Replies
Peter_Jodeleit
Crownpeak employee
Crownpeak employee

Re: Zugriff auf XML-Daten aus einer DQ funktioniert nicht mehr in FS5

Hallo, danke für dein Input. Ein paar Fragen habe ich dazu:

Von welcher v4 erfolgte die Umstellung?

Passiert das auch bei einer Umstellung auf die stabile Version 5.1R4?

Gibt es eine Fehlermeldung oder Warnung?

Hilfreich wäre auch ein exemplarisches Beispiel für den Feldinhalt, wo es nicht funktioniert (also das XML).

Peter
0 Kudos
Noumena
I'm new here

Re: Zugriff auf XML-Daten aus einer DQ funktioniert nicht mehr in FS5

Hallo.

Von welcher v4 erfolgte die Umstellung?

Wir haben von Version 4.2.503.65627 geupdated.

Passiert das auch bei einer Umstellung auf die stabile Version 5.1R4?

Eine Umstellung auf 5.1R4 lässt sich leider momentan nicht auf die Schnelle umsetzen und kann deshalb aktuell nicht von mir beantwortet werden.

Gibt es eine Fehlermeldung oder Warnung?

Nein, es werden keine relevanten Fehler oder Warnings im Log ausgegeben.

Wir haben allerdings noch etwas weiter geforscht und haben herausgefunden, dass nicht alle Datensätze in dieser Datenquelle davon betroffen sind. Darauf hin haben wir direkt in der Datenbank nachgeschaut was FS in der betroffenden Spalte abspeichert.

Funktionierender Datensatz:

<CMS_VALUE name="dtPicture" tag="FS_REFERENCE"><LANG id="DE" set="1"><UID>XXX</UID><UIDTYPE>MEDIASTORE_LEAF</UIDTYPE><REMOTE/></LANG></CMS_VALUE>

Defekter Datensatz:

<CMS_VALUE><LANG id="DE" set="1"><UID>XXX</UID><UIDTYPE>MEDIASTORE_LEAF</UIDTYPE><REMOTE/></LANG></CMS_VALUE>

Jetzt stellt sich für uns die Frage weshalb bei einigen Datensätzen das Mapping in der DB steht und manchmal nicht. Kann es sein, dass sich hier etwas von FS 4 auf 5 geändert hat und die Migration evtl. schief gelaufen ist?

Vielen Dank und viele Grüße!