fabian_koenig
I'm new here

Publizierung von Medien

Jump to solution

Hallo zusammen,

wir haben das Problem, das Bilder nicht korrekt publiziert werden. Wir haben Datenquellen in denen Bilder referenziert werden. Diese Informationen packen wir in eine XML und liefern diese an die Webapp, welche dann das HTML erzeugt. Die Bildurls werden korrekt ausgegeben, allerdings werden die Bidle rnicht auf dem Server gefunden.

Ich vermute, dass Bilder nur publiziert werden, wenn diese auf einer Seite verwendet werden. Dadurch, dass wir diese nur in eine XML packen, werden diese vermutlich nicht publiziert. Hat jemand hierfür eine zeitnahe Lösung?

Liebe Grüße,

Fabian

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
mbergmann
Crownpeak employee
Crownpeak employee

Re: Publizierung von Medien

Jump to solution

Hallo Fabian,

ist denn beim Generierungstask die Option "Medien im Generierungsverzeichnis erzeugen" aktiviert?

Falls ja: Werden die Medien-URLs "ganz normal" per $CMS_REF(...)$ eingebunden? Eigentlich sollten - falls beides der Fall ist - die Medien im Generierungsverzeichnis landen und damit per rsync dann auf dem Server.

Viele Grüße

Michael

View solution in original post

0 Kudos
4 Replies
mbergmann
Crownpeak employee
Crownpeak employee

Re: Publizierung von Medien

Jump to solution

Hallo Fabian,

wie wird denn deployed (rsync, ftp, ...)?

Landen die Bilder denn im Generierungsverzeichnis?

Das XML wird aber "ganz normal" per Template erzeugt, richtig?

Viele Grüße

Michael

0 Kudos
fabian_koenig
I'm new here

Re: Publizierung von Medien

Jump to solution

Hallo Michael,

es wird ein Full-Publish per Rsynch ausgeführt. Die Bilder landen nicht im Generierungsverzeichnis, da diese nicht auf einer anderen Seite verwendet werden. Ja das XML wird in einem JSP-Template generiert.

Idee wäre ein extra Publishjob oder eine Hidden-Page, aber das wären keine schönen Lösungen.

Liebe Grüße,

Fabian

0 Kudos
mbergmann
Crownpeak employee
Crownpeak employee

Re: Publizierung von Medien

Jump to solution

Hallo Fabian,

ist denn beim Generierungstask die Option "Medien im Generierungsverzeichnis erzeugen" aktiviert?

Falls ja: Werden die Medien-URLs "ganz normal" per $CMS_REF(...)$ eingebunden? Eigentlich sollten - falls beides der Fall ist - die Medien im Generierungsverzeichnis landen und damit per rsync dann auf dem Server.

Viele Grüße

Michael

0 Kudos
fabian_koenig
I'm new here

Re: Publizierung von Medien

Jump to solution

Hallo Michael,

vielen Dank! Wir hatten einige Generierungsskripte im Publishjob und der Hakenfür Medien hat leider gefehlt.

Liebe Grüße,

Fabian

0 Kudos