kuaza
Elite Observer

Problem mit Remote Media Zugriff bei gleicher Datenquelle

Jump to solution

Hallo zusammen,

wir haben ein Problem mit dem Remote Media Zugriff.

Es gibt 2 Projekte:

Projekt 1 (Remote Media)

Projekt 2

Projekt 2 hat also Zugriff auf die Medien von Projekt 1.

Beide Projekte haben Zugriff auf die selbe Datenquelle "pressImages", welche als Eingabekomponenten lediglich folgendes besitzt:

<FS_REFERENCE name="cs_image" allowEmpty="no" hFill="yes" imagePreview="yes" sections="no" useLanguages="no">

    <FILTER>

      <ALLOW type="picture"/>

    </FILTER>

    <LANGINFOS>

      <LANGINFO lang="*" label="Image"/>

      <LANGINFO lang="DE" label="Bild"/>

    </LANGINFOS>

    <PROJECTS>

      <LOCAL name=".">

        <SOURCES>

          <FOLDER name="root" store="mediastore"/>

        </SOURCES>

      </LOCAL>

     <REMOTE name="RemoteMedia" autoReleaseAfterUpload="yes"/> (diese Zeile ist nur in Projekt 2 vorhanden)

    </PROJECTS>

  </FS_REFERENCE>

  <CMS_INPUT_TEXT name="cs_text" hFill="yes" singleLine="no" useLanguages="yes">

    <LANGINFOS>

      <LANGINFO lang="*" label="Image description"/>

      <LANGINFO lang="DE" label="Bildbeschreibung"/>

    </LANGINFOS>

  </CMS_INPUT_TEXT>

In Projekt 1 (Remote Media) sind die pressImages ursprünglich gepflegt worden, d.h. dort sieht man ein Vorschaubild (cs_image) und die Beschreibung dazu (cs_text) in der Datenquelle.

In Projekt 2 jedoch sieht man nur die Beschreibung (cs_text) -  das Bild wird nicht angezeigt, da die Referenz nicht vorhanden ist.

Da beide Projekte Zugriff auf dieselbe Datenbank haben und Projekt 2 Remote Media Zugriff auf Projekt 1 müsste dies doch gehen oder?

Hat jmd eine Idee, was hier das Problem sein könnte?

Gruß,

Micha

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
hoebbel
Crownpeak employee
Crownpeak employee

Re: Problem mit Remote Media Zugriff bei gleicher Datenquelle

Jump to solution

Hallo Micha,

bei dieser Konfiguration:

<PROJECTS>

      <LOCAL name=".">

        <SOURCES>

          <FOLDER name="root" store="mediastore"/>

        </SOURCES>

      </LOCAL>

     <REMOTE name="RemoteMedia" autoReleaseAfterUpload="yes"/> (diese Zeile ist nur in Projekt 2 vorhanden)

    </PROJECTS>

und dieser Voraussetzung "In Projekt 1 (Remote Media) sind die pressImages ursprünglich gepflegt worden" kann es sich ja nur um lokale Links handeln {da als Quelle in diesem Projekt ja nur der lokale Mediastore zugelassen wurde}

Statt dessen hätte in dem Originalprojekt die Eingabekomponente bereits so konfiguriert werden werden müssen, dass dort nur Remote Links auf die Medien aus dem eigenen Projekt zulässig sind. (also über eien Remote Verbindung von Projekt 1 zu Projekt 1)

<PROJECTS>

<REMOTE name="{Eigenreferenz}">

<SOURCES>

  <FOLDER name="root" store="mediastore"/>

</SOURCES>

</REMOTE>

{ODER}

<CATEGORY name="standard">

<SOURCES>

  <FOLDER name="root" store="mediastore"/>

</SOURCES>

</CATEGORY>

</PROJECTS>

</FS_REFERENCE>

Die zweite Lösung mit der CATEGORY hat den Vorteil, dass danach in dem Projekt 2 nur eine Remote Verbindung zu Projekt 1 definiert werden muss, die die selbe CATEGORY benutzt (und nicht den selben Namen wie bei der Definition mittels REMOTE

Viele Grüsse aus Dortmund,

  Holger

View solution in original post

0 Kudos
4 Replies
hoebbel
Crownpeak employee
Crownpeak employee

Re: Problem mit Remote Media Zugriff bei gleicher Datenquelle

Jump to solution

Hallo Micha,

bei dieser Konfiguration:

<PROJECTS>

      <LOCAL name=".">

        <SOURCES>

          <FOLDER name="root" store="mediastore"/>

        </SOURCES>

      </LOCAL>

     <REMOTE name="RemoteMedia" autoReleaseAfterUpload="yes"/> (diese Zeile ist nur in Projekt 2 vorhanden)

    </PROJECTS>

und dieser Voraussetzung "In Projekt 1 (Remote Media) sind die pressImages ursprünglich gepflegt worden" kann es sich ja nur um lokale Links handeln {da als Quelle in diesem Projekt ja nur der lokale Mediastore zugelassen wurde}

Statt dessen hätte in dem Originalprojekt die Eingabekomponente bereits so konfiguriert werden werden müssen, dass dort nur Remote Links auf die Medien aus dem eigenen Projekt zulässig sind. (also über eien Remote Verbindung von Projekt 1 zu Projekt 1)

<PROJECTS>

<REMOTE name="{Eigenreferenz}">

<SOURCES>

  <FOLDER name="root" store="mediastore"/>

</SOURCES>

</REMOTE>

{ODER}

<CATEGORY name="standard">

<SOURCES>

  <FOLDER name="root" store="mediastore"/>

</SOURCES>

</CATEGORY>

</PROJECTS>

</FS_REFERENCE>

Die zweite Lösung mit der CATEGORY hat den Vorteil, dass danach in dem Projekt 2 nur eine Remote Verbindung zu Projekt 1 definiert werden muss, die die selbe CATEGORY benutzt (und nicht den selben Namen wie bei der Definition mittels REMOTE

Viele Grüsse aus Dortmund,

  Holger

0 Kudos
kuaza
Elite Observer

Re: Problem mit Remote Media Zugriff bei gleicher Datenquelle

Jump to solution

Hallo Holger,

zu dem damaligen Zeitpunkt war es leider noch nicht bekannt, dass es zu solch einer Remote-Konstellation wird.

Wenn ich deine Lösungsvorschläge (1 oder 2) nun umsetze, müssen alle Links auf die Bilder neu gesetzt werden, da es ja dann kein interner Link mehr ist oder?

Gruß,

Micha

0 Kudos
hoebbel
Crownpeak employee
Crownpeak employee

Re: Problem mit Remote Media Zugriff bei gleicher Datenquelle

Jump to solution

Hallo Micha,

Ja, die Links müssen dann neu gesetzt werden. Das sollte aber auch über ein Skript automatisiert werden können, sofern dieses in dem projekt ausgeführt wird, in dem die Medien vorhanden sind.

Evtl. reicht es auch, wenn man das Ganze templateseitig abfängt.Dann würden in der GUI  korrekterweise die verlinkten Medien nicht angezeigt, aber bei der Ausgabe könnte man prüfen, ob das Zielmedium vorhanden ist und wenn nicht, den Link hartkodiert auf das Remote Projekt manuell zusammenbauen.

Empfehlenswert ist das aber nicht - und ich kann nicht ausschließen, dass es hierbei zu Problemen kommt, die ich momentan übersehe [z.B. dass die Eingabekomponente das Linkziel nicht ausgibt, wenn es dieses nicht gibt]

Viele Grüsse aus Dortmund,

  Holger

0 Kudos
kuaza
Elite Observer

Re: Problem mit Remote Media Zugriff bei gleicher Datenquelle

Jump to solution

Alles klar, danke.

Werden hier ausgiebig testen müssen, bevor wir überhaupt etwas unternehmen, bzw. umbauen, da es um rechte viele Daten geht.

Gruß,

Micha

0 Kudos