jabel
Occasional Observer

GUI wird nicht richtig angezeigt und gibt teilweise keine Daten zurück

Jump to solution

Hallo,

ich habe ein Modul erstellt zum automatischen Hochladen von Videos in ein externes Videoportal, nachdem diese in FirstSpirit hinzugefügt wurden.

Das wird angestoßen durch einen StoreListener der mit Data data = context.showGui(true); ein Eingabefenster anzeigen soll, in dem die nötigen Videoinfos eingegeben werden. Der context wird beim Start des Moduls im Script als GuiScriptContext übergeben und vom Modul an den StoreListener weitergereicht (new LimelightModule(context);).

Wenn man mit "Create Media" ein neues video hinzufügt wird die GUI richtig angezeigt. Fügt man ein Video aber mit drag-and-drop hinzu erscheint zuerst ein kleines Upload-Fenster,

upload_image.png

sobald der Upload fertig ist (elementChanged() mit media als element und Dateigröße > 0) soll die GUI angezeigt werden.

Teilweise passiert es das diese dann nicht in der richtigen Größe erscheint, sondern "zusammengeschoben" ist und erst mit der Maus größer gezogen werden muss.

broken_gui.png

Ich nehme an die Höhe orientiert sich an der Größe des kleinen Upload-Fensters von vorher, kann man dies verhindern?

Ist es möglich über die API auf das Uploadfenster zugreifen und dieses erst zu schließen und damit evtl. das Problem zu beheben?

So sollte das Fenster normalerweise aussehen:

gui.png

Ein weiterer häufiger auftretender Fehler ist, das data als Rückgabe der GUI null ist, obwohl nach Eingabe der nötigen Daten in einigen locales "ok" gedrückt wurde.

Hat jemand eine Idee woran das liegen könnte?

Ist es ein Problem wenn ein Pflichtfeld in einer locale nicht gefüllt ist? Eine Fehlermeldung erscheint nur wenn man diesen Reiter direkt offen hat.

Gruß

Jan

edit:


FirstSpirit Client 4.2.468.50982

Server version: 4.2.468.50982

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
gockel
Crownpeak employee
Crownpeak employee

Re: GUI wird nicht richtig angezeigt und gibt teilweise keine Daten zurück

Jump to solution

Hallo,

bitte die Basisinformationen für solche Postings ergänzen.

Wie z.B. FirstSpirit-Version (vergl. auch Demo Posting)

Stellen Sie sicher, dass context#showGui() im EDT aufgerufen wird?

Wenn nein, tritt das Verhalten auch auf, wenn Sie das sicher stellen?

View solution in original post

0 Kudos
2 Replies
gockel
Crownpeak employee
Crownpeak employee

Re: GUI wird nicht richtig angezeigt und gibt teilweise keine Daten zurück

Jump to solution

Hallo,

bitte die Basisinformationen für solche Postings ergänzen.

Wie z.B. FirstSpirit-Version (vergl. auch Demo Posting)

Stellen Sie sicher, dass context#showGui() im EDT aufgerufen wird?

Wenn nein, tritt das Verhalten auch auf, wenn Sie das sicher stellen?

0 Kudos
jabel
Occasional Observer

Re: GUI wird nicht richtig angezeigt und gibt teilweise keine Daten zurück

Jump to solution

Vielen Dank!!

Daran hatte ich überhaupt nicht mehr gedacht, jetzt funktioniert alles wie gewollt Smiley Happy

0 Kudos