king
I'm new here

FirstSpirit FS 4.2 R4 in combination with Java 7u45

Dear FirstSpirit customers,

starting with the offering of Java 7u45 by Oracle, the FirstSpirit JavaClient in version FS 4.2 R4 cannot be used anymore. Regarding the following BLOG entry, e-Spirit prepared a technical alternative with FirstSpirit 5.0. Up to now, it's unclear, whether FS 4.2 R4 will be updated as well to run with Java 7u45 again.

This leads to questions like:

- what versions of FirstSpirit FS 4.2 R4 do you use in combination with Java 7

- which underlying Java version do you use?

- are you also affected of this problem?

- what are your measurements?

Your opinion and answers are highly appreciated.

Kind regards,

Holger King

Labels (1)
Tags (3)
2 Replies
cewe01
I'm new here

Re: FirstSpirit FS 4.2 R4 in combination with Java 7u45

We plan to use R4.2 until 2017. As far as I know this is the official roadmap by FirstSpirit. But I wonder how this should go if current Java releases are not supported.

Currently we use Java 6, but due to security issues our PC support wont support it any more. Security policies are becoming more stricter than before and so Java 6 must be deinstalled and the update to current Java 7 is obligatory.

So please add Java 7 support also for R4.2!

holger_klatt
I'm new here

Re: FirstSpirit FS 4.2 R4 in combination with Java 7u45

We have to use R4.2 until 2015. This is a time in the official roadmap and supportet time by FirstSpirit. We also have the problem that current Java releases are not supported.

Currently we use Java 1.7.0_21 with integrated jre 1.6.0_45, but due to security issues our PC support wont support it for longer time . Security policies are becoming more stricter than before and so Java 6 must be deinstalled and the update to current Java 1.7.0_45 or higher is obligatory.

So we have the requirement that Java 7 support is availaible for R4.2!