[SOLVED] Warning: macOS High Sierra incompatible with integrated preview in FirstSpirit SiteArchitect

dleinich
Crownpeak Employee
Crownpeak Employee
1 0 205

Update 2017-10-16 14:15: The latest release of FirstSpirit (5.2.1403) includes a fix for this issue. Using FirstSpirit 5.2R14 the integrated preview is working again with macOS High Sierra. See this post for release notes and a download link.

Update 2017-10-02 09:00: We have integrated the new version of the third party component into the FirstSpirit SiteArchitect and are now testing the change. Our plan is to provide a fix with the next release of FirstSpirit in mid October as long as no problems come up during quality assurance.

Update 2017-09-27 14:00: The third party component was updated and we are now integrating the new version into the FirstSpirit SiteArchitect. We plan on providing a fix as soon as possible.

Update 2017-09-26 15:30: The problem is caused by a third party component integrating the preview browser into the SiteArchitect. Both the external preview using a browser installed on your system as well as the ContentCreator are working fine so you are able to work with previews even after an update to macOS High Sierra. We are in talks with the vendor and working on providing a solution as soon as possible.

---

macOS High Sierra, the new operating system version of Apple which was released yesterday is not working with the integrated preview of the FirstSpirit SiteArchitect.

There is currently no workaround for this issue so we strongly recommend not updating to macOS High Sierra if you are depending on the integrated preview of the SiteArchitect.

We are analyzing this issue at the moment and will update this post with further information as soon as it is available.

If you want to contact us regarding this issue, please raise a ticket and refer to our internal bug id 203220.