Java 8 Support in FirstSpirit 5.1

Andreas-Knoor
Crownpeak Employee
Crownpeak Employee
5 8 977

In FirstSpirit 5.1 wird Java in der Version 8 (JDK 1.8) ab dem nächsten Release (02.2015) "passiv unterstützt".

Diese Unterstützung bezieht sich auf die Client-Seite (SiteArchitect) und die Server-Seite (FirstSpirit-Server).

Ein entsprechender Passus wird in das technische Datenblatt aufgenommen.

Der Grund für die rückwirkende Unterstützung von Java 8 liegt im auslaufenden Support von Java 7 durch den Hersteller Oracle ab April 2015.

e-Spirit hat ein hohes Interesse daran seinen Kunden eine Software zur Verfügung zu stellen, die reibungslos mit aktueller und gewarteter Dritt-Software (hier Java) zusammenarbeitet.

Was bedeutet „passiv unterstützt“ konkret in diesem Zusammenhang?

Initial wurde FirstSpirit 5.1 für Java 6 und Java 7 freigegeben.

Die "passive Unterstützung" besagt, dass FirstSpirit 5.1 mit Java 8 offiziell betrieben werden darf.

Gemeldete Fehler werden in jedem Fall analysiert und soweit möglich auch zeitnah behoben.

Wir behalten uns allerdings vor, in Ausnahmefällen ein Bugfixing für Java 8 Themen erst in FirstSpirit 5.2 durchzuführen.    

Tags (4)
8 Comments
Labels