Hotfix FirstSpirit 4.2 for Java 1.7

Frank
Crownpeak employee
Crownpeak employee
1 2 892

Dear Community User,

Last year, Oracle introduced changes as part of its Java 7 update 45. One of those changes is not compatible with FirstSpirit 4.2R4 because it now makes it impossible to transfer parameters to the JavaClient using the current procedure. As you can see in our technical data sheet, our 4th release version of FirstSpirit only supports Java 1.6. Though you have the option of purchasing an expanded 1.6 release version from Oracle to solve this bug, it may not be the most economical solution and it does not always meet the IT security requirements of our customers.

Consequently, we at e-Spirit put our heads together to develop our own solution to fix this bug for our customers.

At that time, we informed the customers who had experienced this bug that we would be providing a solution as quickly as possible. Numerous solution scenarios were being discussed internally at the time, but regardless of what solution was to be implemented, it was clear that making one available would result in additional overheads that that could not be ignored. So, as part of this discussion, we also let our customers know that the solution would come at additional expense.

After weighing carefully the different solution scenarios, it was decided to integrate the bugfix into a build, which would be delivered upon receiving an order. As a result, our customers had the opportunity to quickly purchase a functional expansion from FirstSpirit so that this bug, which we incidently did not cause, would still be fixed for our customers. In our view, we responded to the situation flexibly and quickly so that our customers would not be left "hanging." The next routine release for FirstSpirit 4.2 will include this bug fix. Our solution should not be seen as Java 1.7 Support, rather as a favor to those customers who want to use the 4.2 version of FirstSpirit with Java 1.7.

If you need further information, do not hesitate to contact me

Frank Marasek

Head of CRM

2 Comments
gop1fe
I'm new here

"next routine release for FirstSpirit 4.2 will include..."

That means which build ? When will the build get released?

4.2.497 dosen't include the fix, correct ?

Andreas-Knoor
Crownpeak Employee
Crownpeak Employee

The fix is included in version >= 4.2.501.

Version history
Last update:
‎03-20-2014 09:00 AM
Updated by: