sivaprasad9394
Occasional Collector

DataAccessPlugin With Display in data source column - Filter data source not working?

Jump to solution

Hello Team,

By entering the first char of the data element for filter is not filtering the results. What could be the reason for it?

Story_tags_1.png

Condition_Query_2.png

data_source.png

DataAccess_Plugin.png

It will be helpful for me to understand the issue more.

Thank you.

Labels (2)
0 Kudos
1 Solution

Accepted Solutions
sivaprasad9394
Occasional Collector

Re: DataAccessPlugin With Display in data source column - Filter data source not working?

Jump to solution

Hi Felix,

Thank you for your reply and time.

Problem is related to search Index. After executing the Schedule entry job, the problem got resolved.

Thank you.

 

View solution in original post

0 Kudos
2 Replies
felix_reinhold
Occasional Collector

Re: DataAccessPlugin With Display in data source column - Filter data source not working?

Jump to solution

Hi Siva,

as far as I know the DatasetDataAccessPlugin uses the FirstSpirit Search Index to lookup the datasets.
Therefore it's not just looking in the values/names that you can see in the list, but also all the other fields in the datasets.

"Best Practice", "Electric Vehicle" and "Energy Efficiency" contain a "c" - therefore it's normal that they're visible. For "Automated Driving" I'd guess it's the category. All your categories contain the letter "c".

All you could do is setting the searchRelevancy of those fields to none. But then you wouldn't be able to look them up in the FirstSpirit Search anymore.

Best regards

Felix

0 Kudos
sivaprasad9394
Occasional Collector

Re: DataAccessPlugin With Display in data source column - Filter data source not working?

Jump to solution

Hi Felix,

Thank you for your reply and time.

Problem is related to search Index. After executing the Schedule entry job, the problem got resolved.

Thank you.

 

0 Kudos