[Update] Incompatibility with Java 7 Update 45

Peter_Jodeleit
Crownpeak employee
Crownpeak employee
1 38 1,880

Update:

With current versions of FirstSpirit we implemented a workaround, everything is back to normal.

Versions including the fix:

  • 5.0.420 and newer
  • 4.2.500 and newer (next regular release currently scheduled for July 2014)

Please keep in mind that still JDK-7 for FirstSpirit 4.2 is not supported, i.e. you may encounter bugs with this combination we will and cannot fix. Upgrade to FirstSpirit 5 is recommended.

With todays release of Java 7 Update 75 (short 7u45) start of the FirstSpirit Java-Client is no longer possible. All versions of FirstSpirit are affected!

This is due the fact that Oracle dropped the support of providing parameters in JNLP-files. This changed without prior notice and is not even mentioned in the release notes.

Do not update to Java 7 Update 45!

We are investigating this issue and keep you informed.

=== German version ===

Die heute veröffentlichte Version Java 7 Update 45 (kurz 7u45) verhindert den Start des FirstSpirit Java-Clients. Es sind alle FirstSpirit-Versionen betroffen!

Grund dafür ist, dass Oracle die Möglichkeit ausgebaut hat, Parameter über die JNLP-Datei zu übergeben. Diese Änderung war nicht angekündigt und wird in den "release notes" nicht einmal erwähnt.

Führen Sie keine Aktualisierung auf Java 7 Update 45 aus!

Wir untersuchen das Problem und halten Sie auf dem Laufenden.

38 Comments