rrichter
Crownpeak employee
Crownpeak employee

FirstSpirit Maven Artifacts for external use (Release 1.1)

Without external access to the e­-Spirit internal artifactory it is often very difficult for partners and/or customers to implement FirstSpirit modules on their own.

With the attached files we provide some helpful artifacts and a documentation how to use these.

You can extract the file "maven_repository_artifacts.zip" into your local maven repository, add some additional files from your FirstSpirit installation and you are ready to develop using the firstspirit­-module-­parent-­pom (see firstspirit-­module­-parent-­pom.pdf) to create .fsm-Files and the FirstSpirit Module Installer (see fsmoduleinstaller­-maven-­plugin.pdf) to install modules automatically and also the generic config utility (see

GenericConfig - a utility lib to create <configurable> dialogs) without access to the e-­Spirit artifactory.

Labels (1)
Attachments
Comments

Is it possible to use Https when in Http Connection mode? After hardening our server to only accept HTTPS connections, we can no longer use the com.espirit.ps.maven.ModuleAbstractMojo MoJo:

[ERROR] Failed to execute goal com.espirit.ps.maven:fsmoduleinstaller-maven-plugin:2.1.1:install-module (install-module) on project webapp-fsm: Encountered error during module installation. Exception: java.io.IOException: Unexpected HTTP state: (400) Bad Request, Date=Thu, 09 Nov 2017 15:37:24 GMT / Server=Apache/2.4.6 (Red Hat Enterprise Linux) OpenSSL/1.0.2k-fips / Content-Length=362 / Connection=close / Content-Type=text/html; charset=iso-8859-1 - http://*******:443/servlet/ClientIO/0/o0/1
[ERROR] <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
[ERROR] <html><head>
[ERROR] <title>400 Bad Request</title>
[ERROR] </head><body>
[ERROR] <h1>Bad Request</h1>
[ERROR] <p>Your browser sent a request that this server could not understand.<br />
[ERROR] Reason: You're speaking plain HTTP to an SSL-enabled server port.<br />
[ERROR] Instead use the HTTPS scheme to access this URL, please.<br />
[ERROR] </p>
[ERROR] </body></html>
[ERROR] -> [Help 1]

The method

protected Connection openConnection() {

    return ConnectionManager.getConnection(getServerName(), getServerPort().intValue(), getConnectionMode(),

      getServerUser(), getServerPwd());

  }

should set

ConnectionManager.setUseHttps(true);

when the maven plugin is configured (needs new config parameter).