AriWeissman
Community Manager
Community Manager

Non-Latin characters in DQM CSV downloads

When I open a CSV report in Excel, the default settings sometimes cause accented and non-Latin characters to display incorrectly. Is there some workaround to make Excel display them correctly?

--


Ari Weissman
Sr Director of UX & Community

## If I’ve helped, accept this response as a solution so that other’s can find is more quickly in the future.
## Have thoughts on Crownpeak products? We'd love to hear them. Speak with the Crownpeak Product Team..

0 Kudos
1 Reply
LoftusGreig
Crownpeak Employee
Crownpeak Employee

Re: Non-Latin characters in DQM CSV downloads

Hi @AriWeissman -

 

Thank you for your question.

 

If we understand correctly, it concerns the new CSV (comma separated value) text based reports now available in DQM.

 

Fortunately, there's an easy way to make Excel display special characters properly.

 

When you open a CSV report in Excel, default settings may cause accented and non-Latin characters to display incorrectly. There are workarounds to make Excel display them as intended.

 

Example: … improve your system’s productivity and efficiency

 

 

Method 1 - Open the CSV file in Notepad and save a copy with UTF-8 encoding

If you are using Windows, the Notepad text editor can save the file with a marker to indicate that it contains special characters. This will make recent versions of Excel open it correctly. To do this, start Notepad and open the CSV file. The open Notepad’s File menu and choose “Save As”. At the bottom of the Save As dialog box, there’s a drop down chooser to change the file’s encoding. Click the chooser and select “UTF-8”, then click “Save”.

 

image001.png

 

 

 

 

 

 

 

 

 

 

 

When you open the CSV file in Excel, accented or special characters should be displayed correctly.

 

Please note – this adds a marker at the start of the CSV file. Although it is recognised by many applications and works with Excel, not all applications are guaranteed to understand it.

 

 

Method 2 – Change the encoding when opening the CSV file in Excel

When you open comma separated CSV file in Excel, it may not present the text import wizard, where you can specify file encoding and delimiter options.

 

In a blank workbook, open Excel’s Data ribbon and click “Get Data” at the left of the toolbar.

 

From the drop-down menu, choose “From File” >> “From Text/CSV”.

 

image003.png

 

 

 

 

 

 

 

 

This opens a file chooser. Select the CSV file and click “Import” to open the import wizard:

 

image005.png

 

 

 

 

 

 

 

 

 

 

When the import wizard appears, open the “File origin” drop-down chooser at the top left and select the following entry:

 

65001: Unicode (UTF-8)

 

The delimiter should default to “Comma”.

 

After UTF-8 encoding has been chosen, click “Load” to bring the data into Excel.

0 Kudos